Printing (staff and students)
April 10, 2025 11:24AM BST
[Monitoring] We are aware of an issue with print release, some users were seeing a prompt to update drivers.
We have applied a fix for this issue, however it may take some time for this to take effect.
If you are still seeing an error against Print Release printers, restarting your PC should clear it.
We apologise for the inconvenience
April 10, 2025 12:02PM BST
[Monitoring] We believe that this issue has been resolved, however we are continuing to monitor the issue.
If you sent jobs to print earlier this morning and they do not appear on the printer, unfortunately you will need to resend them.
We apologise for this inconvenience
April 10, 2025 2:15PM BST
[Resolved] We believe this issue to be resolved, however if you are still experiencing issues please contact the Service Desk