March 31, 2025 8:27AM BST
[Investigating] We are currently experiencing issues with the exam timetables site and are investigating currently.
March 31, 2025 8:45AM BST
[Investigating] Please contact your own school for exam locations.
March 31, 2025 10:08AM BST
[Resolved] This issue has now been resolved