Issues with EzyVet serviceOperational

Components

Other services



March 18, 2025 10:10AM GMT
[Investigating] EzyVet is currently unavailable. Third party supplier issue - updates via their status page: status.idexxsoftware.com

March 18, 2025 2:17PM GMT
[Resolved] Provider now reporting EzyVet as operational

Back to current status