Issue with Print ReleaseOperational

Components

Printing (staff and students)



March 17, 2025 9:02AM GMT
[Investigating] There are currently issues affecting Print Release Colour and Black & White. IT Services are currently investigating.

March 17, 2025 1:28PM GMT
[Resolved] This issue is now resolved

Back to current status