March 14, 2025 2:05PM GMT
[Investigating] The programme and unit catalogues on the University of Bristol website are currently experiencing a total disruption and are unavailable. Users are unable to access any functionality provided by these services. We are working to resolve this issue as a priority and hope to restore service soon.
March 17, 2025 9:50AM GMT
[Monitoring] Access to the Unit Programme Catalogue has resumed but monitoring continues
March 26, 2025 9:04AM GMT
[Resolved] This issue is now resolved