Unit & Programme Catalogue performance issuesOperational

Components

Websites and Intranets



February 21, 2025 12:10PM GMT
[Investigating] The Unit & Programme Catalogue is currently experiencing performance problems. The issue is being investigated

February 26, 2025 8:24AM GMT
[Resolved] This issue is now considered to be resolved. Should there be any further issues affecting the UPC they will be posted here.

Back to current status