January 20, 2025 11:46AM GMT
[Identified] The Unit & Programme Catalogue is currently experiencing performance problems. The issue is being investigated, and we hope to have performance restored shortly.
January 21, 2025 4:40PM GMT
[Monitoring] Apologies for the disruption to this service. ITS have been working with Jisc to reduce traffic and improve the Unit & Programme Catalogue performance. We are still seeing some intermittent issues, and we will be continuing to monitor closely.
January 23, 2025 9:26AM GMT
[Resolved] This issue has been resolved, The Unit & Programme Catalogue service has been restored.