Issues with Halo ITSM toolOperational

Components

Other services



December 12, 2024 9:57AM GMT
[Investigating] There are currently issues with the Halo ITSM tool This is a known issue that has been recognised by Halo on their own status page status.haloservicesolutions.com

December 12, 2024 10:44AM GMT
[Resolved] This issue is now resolved. Halo are still monitoring the situation.

Back to current status