Microsoft IssuesOperational

Components

Microsoft Office 365 (Outlook, OneDrive)



November 25, 2024 10:13AM GMT
[Investigating] Microsoft have reported some issues affecting Outlook and other MS services this morning on their service health pages. Affected services: Exchange Online, Microsoft 365 suite, Microsoft Teams MS are currently investigating the root cause. Further updates to follow as we receive them from MS.

November 25, 2024 11:42AM GMT
[Investigating] Microsoft have provided additional detail on the user impact of the ongoing incident. Namely, this will impact Microsoft Teams, SharePoint Online, Outlook web app, Outlook desktop client and Microsoft Bookings (this service is built on Exchange and there are reports that this is impacted too). Next update from MS expected at 12:00 GMT.

November 25, 2024 1:28PM GMT
[Investigating] The following update has been provided by MS at 12:00 GMT "Root cause identified, and rollback of change has commenced" The service disruption is known to be affecting the following services: Microsoft Teams SharePoint Online (search) Outlook Web App Outlook desktop client Microsoft Bookings Microsoft Fabric Microsoft Defender for Office 365 Universal Print Next update to be provided at 14:00 GMT

November 25, 2024 3:44PM GMT
[Investigating] Update provided by Microsoft at 14:30 GMT "We’re monitoring the progress of the fix, which has been deployed to approximately 60% of the affected environments"

November 26, 2024 1:38PM GMT
[Monitoring] Further update provided by Microsoft today (26/11) "The impacted services are now operating at expected levels, and the incident should no longer be presenting any user impact for most users. Microsoft have moved into a period of extended reporting to ensure the previously impacted services remain stable. As soon as this period is over the incident will be considered resolved"

November 28, 2024 12:25PM GMT
[Resolved] Final update from Microsoft as follows: After a period of extended monitoring, we’ve confirmed through customer reports and service health telemetry that the issue is resolved.

Back to current status