September 12, 2024 11:29AM BST
[Identified] Due to a leak in the Arts & Social Science Library (ASSL) the Staff IT Counter has had to be relocated to the reception area of 5 Tyndall Avenue.
FixMyTek have relocated to Senate House.
Student Mobile & Laptop Clinic will not be open on 12/09/2024 or 13/09/2024.
Further updates to follow.
September 13, 2024 1:40PM BST
[Identified] Services will remain in their temporary locations today (Friday 13 Sept) with the aim being a return to ASSL on Monday 16th September.
Student Mobile & Laptop Clinic will remain closed today.
September 17, 2024 8:18AM BST
[Resolved] This issue is now resolved and all services have returned to the Arts & Social Science Library (ASSL) from Monday 16 September.