Power issues at Dorothy Hodgkins BuildingOperational

Components

Wired network, Wireless network



August 14, 2024 12:44PM BST
[Investigating] There are currently power issues reported at DHB. These are being investigated by Estates team. Wired & wireless network therefore affected. Further updates to follow.

August 14, 2024 12:58PM BST
[Resolved] The issues at DHB have now been resolved.

Back to current status