Unit Registration Details within StudentInfo is not currently workingOperational

Components

Student Information Systems (SITS), Other services



June 10, 2024 11:49AM BST
[Identified] The option "Unit Registration Details" within StudentInfo is not currently working. To access this information, please follow the instructions for viewing your assessment information provided here: bristol.ac.uk/students/support/academic-advice/outcomes/view-assessment-details-and-results

June 10, 2024 1:55PM BST
[Resolved] This issue has now been fully resolved.

Back to current status