Issues with phone system affecting IT Services & Student ServicesOperational

Components

Telephony



May 29, 2024 10:53AM BST
[Investigating] We are currently seeing issues with the phone system affecting IT Services & Student Services whereby calls are not connecting to available agents. This has been reported to the Unified Comms team who are investigating.

May 29, 2024 11:04AM BST
[Resolved] This issue is now resolved.

Back to current status