Issues at Deans Court (North Block)Operational

Components

Wired network, Wireless network



May 23, 2024 9:54AM BST
[Investigating] IT Services (Networks) are currently investigating some issues affecting Deans Court (North Block). These are believed to be related to electrical problems. Further updates to follow as more is known.

May 23, 2024 11:05AM BST
[Resolved] This issue is now resolved and Deans Court is back online

Back to current status