Microsoft Office 365 (Outlook, OneDrive)
May 22, 2024 3:48PM BST
[Investigating] There is currently a delay in creation of alumni accounts after eligible students have opted in via the email link they are being sent in leavers communications.
If you have followed all these steps but have not received a confirmation email then please remain assured that your account will be created in due course. Apologies for any inconvenience this may cause.
In the instance that you have clicked on the link and have received a message to say that you are ineligible but you feel you should be eligible then please contact the Service Desk.
September 10, 2024 12:02PM BST
[Resolved] This incident has now been resolved.