Issues with analogue phones in OPH, MVB and Chemistry buildingsOperational

Components

Telephony



May 3, 2024 9:09AM BST
[Investigating] Issues have been reported with the analogue phone system in Old Park Hill, Merchant Venturers Building and Chemistry. This is currently being investigated.

May 3, 2024 4:15PM BST
[Resolved] This incident is now resolved.

Back to current status