Issues with LucidLink serviceOperational

Components

Other services



April 29, 2024 3:57PM BST
[Investigating] Issues have been identified with the Lucid Link service - mainly used by Department of Film & Television. Investigations are ongoing but the problem is at the suppliers end.

May 1, 2024 8:01AM BST
[Resolved] The issue with Lucid Link is now resolved.

Back to current status