Microsoft Office 365 (Outlook, OneDrive)
April 3, 2024 2:31PM BST
[Investigating] Microsoft Outlook Issue: Some users may be unable to download attachments from Outlook on the web
While we’re focused on remediation, users may sign out and back into Outlook on the web to temporarily mitigate the impact.
Current status: Development of the fix continues and once complete, we'll deploy it to our internal testing environment and validate that it resolves this issue without further complications.
Root cause: A recent update, intended to improve the reliability of Outlook on the web, contains a code configuration issue that's causing long running sessions and may prevent attachment downloads.
April 9, 2024 8:01AM BST
[Identified] Latest update supplied by Microsoft at 20:48 on 08 April 2024 is as follows:
Current status: We've completed the internal validation process and started the fix deployment to the affected environment. We anticipate this will finish and remediate the impact by our next scheduled update on Thursday, April 11, 2024 at 10:00 PM GMT+1
April 15, 2024 3:17PM BST
[Resolved] This incident is now considered as Resolved based on the update from Microsoft:
We're continuing to track the fix discussed previously in EX764050, and confirmed it's continuing to saturate throughout the affected environment, although the process is taking longer than expected. We expect it may complete by our next scheduled update on Tuesday, 16 April 2024 at 00:00 BST