April 3, 2024 9:58AM BST
[Investigating] There is currently an issue for users who are trying to access Rx Works. This is being investigated. Further updates to follow.
April 3, 2024 3:49PM BST
[Resolved] Local Faculty IT Support (FITS) team report that this issue has now been resolved. This has been confirmed with users at Langford.