Print Release Issue (Students)Operational

Components

Printing (staff and students)



March 27, 2024 10:53AM GMT
[Investigating] There is currently an issue with Print Release printers whereby students balance is showing as zero when trying to print despite the fact that their Uniflow accounts show them in credit. This is resulting in them not being able to print. IT Services are currently investigating in conjunction with Canon.

March 28, 2024 10:09AM GMT
[Resolved] This issue has now been resolved.

Back to current status