Network down in Queens LibraryOperational

Components

Wired network, Wireless network



March 18, 2024 9:42AM GMT
[Investigating] There is currently no network (wired or wireless) in Queens Library. Network Campus team are investigating the issue.

March 18, 2024 10:03AM GMT
[Resolved] This issue is now Resolved.

Back to current status