Performance issues in SITS eVision Operational

Components

Student Information Systems (SITS)



February 27, 2024 4:12PM GMT
[Investigating] We are experiencing performance issues in SITS eVision at the moment, IT Services are investigating. We hope to resolve this issue soon, apologies for the inconvenience.

February 27, 2024 5:11PM GMT
[Monitoring] Immediate SITS eVision performance issue is now been resolved, albeit we are still monitoring the service

March 4, 2024 8:03AM GMT
[Resolved] This issue is now Resolved.

Back to current status