Issues with Academic Programme and Unit CatalogueOperational

Components

Websites and Intranets



February 23, 2024 3:30PM GMT
[Investigating] The Academic Programme and Unit Catalogue is currently showing as unavailable. Investigations are ongoing as to what is causing this.

February 23, 2024 4:42PM GMT
[Resolved] This issue has been resolved

Back to current status