November 30, 2023 12:38PM GMT
[Investigating] We are seeing reports of some student services pages being down currently including wellbeing and assessment support.
This is currently being investigated.
If you need to contact the Wellbeing team in the meantime please call 0117 456 9860.
Student Services can also be contacted on 0117 428 3000
November 30, 2023 1:13PM GMT
[Resolved] The affected pages are now displaying again.