October 16, 2023 9:04AM BST
[Investigating] Reports received that Syllabus+ system is currently down. Investigations currently taking place. Further updates to appear here.
October 16, 2023 10:54AM BST
[Resolved] Syllabus+ web room booking system is now back in service.