O365 A5 Faculty Licences Operational

Components

Microsoft Office 365 (Outlook, OneDrive)



September 26, 2023 11:02AM BST
[Identified] New members of staff are currently unable to log into their O365 accounts due to a lack of available O365 A5 Faculty Licenses. Purchase of new licenses in in progress. ETA to be confirmed shortly.

September 27, 2023 11:08AM BST
[Resolved] This has been resolved

Back to current status