Microsoft Office 365 (Outlook, OneDrive)
September 8, 2023 11:19AM BST
[Identified] We are aware of issues with the Resource Calendar Management system, caused by some Microsoft changes. This is resulting in delays in the creation of new calendars, or in processing changes to existing calendars. We are investigating, and apologise for the inconvenience.
September 15, 2023 5:05PM BST
[Resolved] This should be resolved. However please let us know if you see any errors when managing your resource calendar.