QREG is currently unavailable Operational

Components

Administrative systems (Finance & HR)



August 31, 2023 8:22AM BST
[Investigating] We are aware QREG is currently unavailable, IT Services teams are investigating the issue as a matter of urgency. Further updates will be posted here in due course. Apologies for any inconvenience this may cause.

August 31, 2023 8:59AM BST
[Resolved] IT Services have restored service, QREG is now available. If you have any further issues, please contact the Service Desk. Apologies again for any inconvenience caused.

Back to current status