Issues with University phonesOperational

Components

Telephony



July 28, 2023 11:44AM BST
[Investigating] We are currently experiencing issues with the University phone system. Calls are are not getting connected. This is effecting all University VoIP phones uncluding: Langford Vets Student Services IT Services We are investigating the issue

July 28, 2023 1:57PM BST
[Resolved] Phones service has now been resolved

Back to current status