July 6, 2023 10:25AM BST
[Investigating] We are currently seeing reports about external users not able to ring into the University.
Internal calls are working fine.
We are currently investigating the issue, we will update when we know more.
July 6, 2023 2:18PM BST
[Resolved] The issue has now been resolved