Microsoft Teams reported issuesOperational

Components

Microsoft Office 365 (Outlook, OneDrive)



June 28, 2023 2:04PM BST
[Identified] Microsoft are investigating an issue where some users may be unable to access Microsoft Teams, via the web or desktop app. They hope to have it fixed soon

July 28, 2023 11:34AM BST
[Resolved] This have now been resolved

Back to current status