Issue with some Distribution GroupsOperational

Components

Microsoft Office 365 (Outlook, OneDrive)



June 22, 2023 11:23AM BST
[Investigating] Emails sent to distribution groups which list predefined groups in their membership will result in a non-delivery message and the email will not be sent to members of the pre-defined group(s). We are investigating this. If you know the individual pre-defined group addresses you can send to these direct as a workaround. This page may assist in finding these addresses: uob.sharepoint.com/sites/predefined-groups

June 29, 2023 5:09PM BST
[Resolved] This issue has been resolved

Back to current status