Blackboard issuesOperational

Components

Blackboard, RePlay and Library systems



April 20, 2023 2:11PM BST
[Investigating] There have been issues with Turnitin, Blackboard, Qwickly Attendance today. Blackboard are investigating. Please see the DEO blog for latest updates: blackboard.blogs.bristol.ac.uk

April 20, 2023 4:42PM BST
[Resolved] This issue is now resolved. Please see the DEO bog for further information. blackboard.blogs.bristol.ac.uk

Back to current status