Printing issuesOperational

Components

Printing (staff and students)



March 14, 2023 10:15AM GMT
[Investigating] There are printing issues this morning and some print jobs are not being sent to the printers. We are working now to resolve this.

March 14, 2023 12:19PM GMT
[Resolved] Printing has now been restored

Back to current status