Microsoft Office 365 (Outlook, OneDrive)
January 27, 2023 9:53AM GMT
[Identified] We are currently receiving reports about Outlook web calendar not updating currently, this is also affecting Apple Native Client and the Outlook app on MacOS.
Microsoft are still investigating the issue.
February 24, 2023 8:57AM GMT
[Resolved] This has now been resolved by Microsoft