Microsoft Teams issuesOperational

Components

Microsoft Office 365 (Outlook, OneDrive)



January 10, 2023 1:05PM GMT
[Investigating] Microsoft report Teams message delays and failures. This is affecting all users worldwide. Microsoft are investigating the issue.

January 11, 2023 11:52AM GMT
[Resolved] This is now resolved.

Back to current status