Microsoft Office 365 (Outlook, OneDrive)
September 7, 2022 4:01PM BST
[Investigating] It has been reported that Microsoft are currently experiencing issues, resulting in unexpected behavior from Teams and other 365 apps. One symptom is Teams messages getting delayed.
Microsoft are currently investigating.
September 8, 2022 3:35PM BST
[Resolved] Microsoft have now resolved this issue