Issues accessing Outlook mailboxesOperational

Components

Microsoft Office 365 (Outlook, OneDrive)



June 21, 2022 11:42AM BST
[Investigating] We are aware of an issue affecting access to some Outlook mailboxes via web or the Outlook desktop application. Microsoft are investigating and we will update this page when we have more information.

June 27, 2022 3:20PM BST
[Resolved] This has been resolved

Back to current status