Information Security - Alerts
February 24, 2022 8:51AM GMT
[Investigating] Phishing emails purporting to be from the HR department have been sent to some University accounts.
We are investigating this now, if you have received one of these emails please delete it.
If you have clicked on the link in the email please contact the IT Service Desk bristol.ac.uk/it-services
For more information on phishing emails please familiarise yourself with the guidance linked below.
Learn how to spot phishing emails with our guide at bristol.ac.uk/infosec/protectyou/phishing
Find general guidance on how to be cyber aware visit bristol.ac.uk/cyber-aware March 11, 2022 9:41AM GMT
[Resolved] We continue to receive phishing emails – and expect to receive more – targeting students and staff to try to convince them to provide login information such as passwords or to click a link to a malicious site.
We can all play a part in helping stop phishing attempts from succeeding by being familiar with how to spot suspicious emails. Please read our guidance around phishing and other online threats - bristol.ac.uk/infosec/protectyou/phishing