Phishing incident: Education Maintenance AllowanceOperational

Components

Information Security - Alerts



October 5, 2021 1:32PM BST
[Investigating] We are aware of a current phishing attack with email subject: Education Maintenance Allowance. If you see this email, please do not click on the link. Simply delete the email. You do not need to inform the IT Service Desk. IT Services are working to stop the messages and will remove them from inboxes. If you have clicked the link and provided your University username and password please contact the IT Service Desk bristol.ac.uk/it-services/contacts. For information on how to identify and deal with phishing emails please see our Information page on the subject: bristol.ac.uk/infosec/protectyou/phishing If you have any questions regarding this, or any other Information Security matter please contact the Information Security team at cert@bristol.ac.uk.

October 5, 2021 1:54PM BST
[Monitoring] We are removing messages from inboxes and site linked in message blocked from on-campus access.

October 5, 2021 2:14PM BST
[Monitoring] Messages have now been removed from inboxes. If you have clicked the link and provided your University username and password please contact the IT Service Desk bristol.ac.uk/it-services/contacts.

October 5, 2021 4:03PM BST
[Resolved] The Incident has been completed.

October 5, 2021 4:12PM BST
[Monitoring] We are checking reports that all emails may not have been purged. If you have clicked the link and entered your username and password, please immediately change your password via the 'Change my password' link at bristol.ac.uk/it-services/password

October 7, 2021 10:59AM BST
[Resolved] This incident has been resolved.

Back to current status