Outlook Desktop issuesOperational

Components

Microsoft Office 365 (Outlook, OneDrive)



August 4, 2021 7:18PM BST
[Investigating] Some users are experiencing issues with Outlook desktop calendar causing calendar and Outlook to freeze or go slow. This is being investigated.

October 7, 2021 11:24AM BST
[Resolved] This has been resolved however if you are still having issues please log an incident with the service desk.

Back to current status