Issues with Microsoft Office, Teams, Sharepoint and DynamicsOperational

Components

Microsoft Office 365 (Outlook, OneDrive)



March 15, 2021 10:10PM GMT
[Investigating] Microsoft have alerted us to issues with numerous services, including, authenticating into Microsoft Teams, Office and/or Dynamics, Xbox Live, and the Azure Portal

March 17, 2021 5:37PM GMT
[Resolved] This issue has been resolved

Back to current status