Phishing Alert: Outlook is validating active and valid accountsSecurity Issue

Components

Information Security - Alerts



February 2, 2021 12:47PM GMT
[Investigating] A phishing email has been circulated to some staff and students. The text includes: This is to notify all account users; Outlook is validating active and valid accounts. Please do not click the link. We are working to remove messages form inboxes and block links.

February 2, 2021 4:36PM GMT
[Resolved] Emails removed from inboxes and links blocked shortly after attack identified.

Back to current status