Sharepoint running slowOperational

Components

Microsoft Office 365 (Outlook, OneDrive)



December 11, 2020 3:10PM GMT
[Investigating] Sharepoint is experiencing issues and is running very slowly or is inaccessible for some users.

December 11, 2020 3:58PM GMT
[Investigating] This is due to a Europe wide Microsoft issue . Impacted services include, but are not limited to: SharePoint Online OneDrive for Business Microsoft Teams Microsoft 365 admin center

December 13, 2020 11:10PM GMT
[Resolved] Issue resolved by Microsoft

Back to current status