Phishing alert: Some staff and students have received a phishing email with the subject 'Royal Mail UK - Courier was unable to deliver the parcel to you.'Security Issue

Components

Information Security - Alerts



December 8, 2020 8:00AM GMT
[Identified] Yesterday from around 5.20 pm on 7 December some staff and students received an email with the subject 'Royal Mail UK - Courier was unable to deliver the parcel to you.' This is a phishing email. Please do not click on any links in the message and delete the email. If you have provided information via the link please contact the IT Service Desk, service-desk@bristol.ac.uk, for advice. See the guidance on dealing with phishing emails at bristol.ac.uk/infosec/email-threat/identifying-threats We are working to block and remove the message from inboxes.

December 8, 2020 9:49AM GMT
[Monitoring] The email and link have been blocked and messages purged from inboxes.

December 8, 2020 3:49PM GMT
[Resolved] This incident is resolved.

Back to current status