Phishing incidentOperational

Components

Information Security - Alerts



July 20, 2020 2:44PM BST
[Identified] We are aware of a phishing email entitled *unemployment payment* please do not click on the link and delete the message.

July 22, 2020 7:54PM BST
[Resolved] This has now been resolved

Back to current status