Phishing e-mailsOperational

Components

Information Security - Alerts



June 22, 2020 10:44AM BST
[Identified] We are aware of various phishing emails pertaining to be from UOB staff that look similar to the message below, this is not genuine and please do not click the link or enter any details Take action before Tuesday bf7e36927947fc840890788f4ff26b14

June 29, 2020 3:29PM BST
[Resolved] Haven't seen any emails for over a week

Back to current status