Voicemail Phishing messageSecurity Issue

Components

Information Security - Alerts, Microsoft Office 365 (Outlook, OneDrive)



May 15, 2020 9:39AM BST
[Identified] We have received reports that people are receiving voice message emails from a University email address. The message comes with a note asking that they download the message. This is a phishing attempt so please do not download the content. Anyone who has tried to download this should contact the Service Desk for further advice.

June 8, 2020 10:59AM BST
[Resolved] This as now been resolved.

Back to current status