Administrative systems (Finance & HR), Authentication (Single Sign On), Blackboard, RePlay and Library systems, Departmental Filestore, myERP - Finance & HR system, Printing (staff and students), Remote desktop (staff, student, other), Research Data Storage Facility (RDSF), Student Information Systems (SITS), Telephony, Websites and Intranets, Wired network, Wireless network, Other services
April 29, 2020 11:13PM BST
[Investigating] We are aware of network issues across the University campus, we apologise for any inconvenience and will update the status page as soon as we more information
April 30, 2020 2:39AM BST
[Identified] The network issue has been resolved, however, there are continued issues with a number of services that are being restored and the status will be updated here, apologies for the inconvenience
April 30, 2020 9:22AM BST
[Resolved] All services have now been resolved