Information Security - Alerts
March 25, 2020 12:21PM GMT
[Identified] We have identified a phishing email going around to UOB email addresses, HMRC - Tax Refund - GOV-UK
This is a phishing email, please do not click any link that it contains.
March 25, 2020 7:58PM GMT
[Resolved] Phishing emails deleted and link blocked